aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaul Harrison <paul@harrison.sh>2024-08-31 15:45:16 +0100
committerPaul Harrison <paul@harrison.sh>2024-08-31 15:45:16 +0100
commitc66ea168ba4a6fbc6acd8e0e92e299c9649dbdf3 (patch)
treef56ba041ee71536c1523e155c12fe5175cab23d6 /pyproject.toml
Add initial project structure
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..cfd170b
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+[tool.poetry]
+name = "analysis"
+version = "0.1.0"
+description = ""
+authors = ["Paul Harrison <paul@harrison.sh>"]
+readme = "README.md"
+packages = [{include = "analysis", from = "src"}]
+
+[tool.poetry.dependencies]
+python = ">=3.12,<3.13"
+jupyter = "^1.1.1"
+numpy = "^2.1.0"
+pandas = "^2.2.2"
+matplotlib = "^3.9.2"
+seaborn = "^0.13.2"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"