aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaul Harrison <paul@harrison.sh>2022-12-15 15:59:38 +0000
committerPaul Harrison <paul@harrison.sh>2022-12-15 16:02:01 +0000
commit3899da2f5270d61fa86b090e35f92323c82a5161 (patch)
tree71199b3baf30b41c2c9eb58b43b277933d63956e /pyproject.toml
chore: Initial project setup
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..bb7671b
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,16 @@
+[tool.poetry]
+name = "poker"
+version = "0.1.0"
+description = "Single poker hand ranking service."
+authors = ["Paul Harrison"]
+readme = "README.md"
+
+[tool.poetry.dependencies]
+python = ">=3.11,<3.12"
+
+[tool.poetry.group.test.dependencies]
+pytest = "^7.2.0"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"