aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaul Harrison <paul@harrison.sh>2022-11-18 13:18:07 +0000
committerPaul Harrison <paul@harrison.sh>2022-12-15 16:02:14 +0000
commit8a7147441acf3c6e1320ce89dcabac17248bd463 (patch)
tree2979eeb334eb61d3e3087ffbcfb124bcaaa70595 /pyproject.toml
parent69dee5d5a5d75ef338ec241d95a0a5a11ed14eb8 (diff)
chore: Add linting configuration
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 13 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5b4b998..7308ae2 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "poker"
-version = "0.2.1"
+version = "0.2.2"
description = "Single poker hand ranking service."
authors = ["Paul Harrison"]
readme = "README.md"
@@ -12,6 +12,18 @@ pydantic = "^1.10.2"
[tool.poetry.group.test.dependencies]
pytest = "^7.2.0"
+
+[tool.poetry.group.lint.dependencies]
+black = "^22.10.0"
+isort = "^5.10.1"
+flake8 = "^5.0.4"
+flake8-builtins = "^2.0.1"
+flake8-blind-except = "^0.2.1"
+flake8-eradicate = "^1.4.0"
+flake8-use-fstring = "^1.4"
+mypy = "^0.991"
+pydocstyle = "^6.1.1"
+
[build-system]
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"