aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorPaul Harrison <paul@harrison.sh>2022-11-20 15:13:16 +0000
committerPaul Harrison <paul@harrison.sh>2022-12-15 16:02:14 +0000
commit9baafc80ed889c232587cf5d4cfaa2db44d1825a (patch)
tree13371c1220a8eabbc0932d30cc9475b98b984c3b /pyproject.toml
parentb4ba284dcc20563b9b7dde770b7c9f67c6b25e76 (diff)
feat: Hand ranking API
Hand ranking API with a health check root endpoint and rank endpoint.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 036f515..1df9ae7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,17 +1,21 @@
[tool.poetry]
name = "poker"
-version = "1.1.0"
+version = "2.0.0"
description = "Single poker hand ranking service."
authors = ["Paul Harrison"]
readme = "README.md"
[tool.poetry.dependencies]
python = ">=3.11,<3.12"
+fastapi = "^0.87.0"
+loguru = "^0.6.0"
pydantic = "^1.10.2"
+uvicorn = "^0.20.0"
[tool.poetry.group.test.dependencies]
coverage = "^6.5.0"
pytest = "^7.2.0"
+httpx = "^0.23.1"
[tool.poetry.group.lint.dependencies]